ServiceRocket Apps Status

Support Portal
Incident Report for ServiceRocket
Resolved
Between 07:14 UTC to 07:30 UTC We experienced issue with our support portal. This issue has now been resolved and the service is operating normally.
Posted Nov 09, 2020 - 07:30 UTC
Investigating
We are currently experiencing a problem with our support portal. If you need urgent help, you may contact us via live chat.
Posted Nov 09, 2020 - 07:14 UTC
This incident affected: Support Jira Service Desk (Service Desk Internal, Service Desk Portal, Service Desk Email Requests).