ServiceRocket Apps Status

SR Marketplace Portal
Incident Report for ServiceRocket
Resolved
Between 03:40 UTC to 03:59 UTC We experienced issue with our marketplace portal. This issue has now been resolved and the service is operating normally.
Posted Nov 02, 2020 - 03:59 UTC
Investigating
We are currently experiencing a problem with our marketplace portal. If you need urgent help, you may contact us via live chat.
Posted Nov 02, 2020 - 03:40 UTC
This incident affected: Marketplace (Portal).