ServiceRocket Apps Status

Multiple apps unavailable due to SSL certificate issue
Incident Report for ServiceRocket
Resolved
This incident has been resolved. The root cause of this incident is SSL certificate expiry.
Posted Jul 10, 2020 - 13:46 UTC
Update
We are continuing to investigate this issue.
Posted Jul 10, 2020 - 13:15 UTC
Investigating
We are currently investigating this issue.
Posted Jul 10, 2020 - 13:14 UTC