Connector for Salesforce & Jira Cloud: Non-admin Jira users are encountering the "Project is not bound to any connection" error when accessing the Associations panel
Incident Report for ServiceRocket Apps
Resolved
The fix was released and we can confirm the issue has been rectified.
Posted Dec 21, 2022 - 07:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2022 - 06:18 UTC
Investigating
Due to the recent release, any Jira users without "Administer Project" permission are encountering the "Project is not bound to any connection" error when accessing the Associations panel.

Currently, the Development Team is aware of this and working on the fixes.

We appreciate your patience.
Posted Dec 21, 2022 - 03:39 UTC